Copying projects

You can export a test project from a workspace and import it into another workspace.

About this task

If you export test assets to an archive file and then import them to another project, ensure that both project names are the same. Otherwise, you might not be able to locate your imported test assets.
Note: You can also export the test project with all the dependent assets in to an archive file. See Copying test assets with dependencies for the instructions.

Procedure

  1. Start HCL OneTest™ Performance, and select the source workspace.
  2. Export the test project to an archive file. For instructions, see Exporting resources to an Archive file. Datapools can be located either in the same project as the tests that use them or in different projects. Be sure to export all the datapools that the exported tests require.
  3. If the target workspace is on a different computer, transfer the archive file to a location that is accessible to that computer.
  4. Start HCL OneTest Performance, and select the target workspace.
  5. Click File > Import. Expand the General folder, and click the Existing Projects into Workspace icon; then click Next.
  6. Click Select archive file, and then click Browse to select the archive file. Click Finish to import the source project from the archive file into the target workspace.
  7. Optional: If the imported project contains custom code or tests that have been run, you might need to change the Java™ build path. The following examples are cases that might require a change to the Java build path:
    • The Java build path was manually changed in the project from which it was exported. In this case, the same changes need to be made in the imported project. While importing, you are asked whether to overwrite the class path file, which stores the Java build path for project. Answering Yes reduces the likelihood that the build path will need to be changed.
    • The project was imported onto a different computer with a different Java installation configuration. In this case, missing libraries must be removed from the build path.
    • The project was imported into a workspace on a different disk drive. When you are asked whether to replace the class path file, answering No reduces the likelihood that the build path will need to be changed.

    For instructions on changing the build path, see the Java Build Path page.

What to do next

If you encounter errors after importing a test project or when using an existing workspace with a new version of the product, you might need to delete .java files from the src folder in the workspace:
  1. Click Window > Open Perspective > Resource to open the Resource perspective.
  2. In the Navigator window, expand the test project folder, and locate the src folder.
  3. Delete all .java files in the src folder, except for those that contain custom code.
  4. Return to your test perspective: Click Window > Open Perspective, and select Performance Test (or Service Test, if you are using Rational® Service Tester).
Feedback