Configuring the workbench for NTLMv2 authentication

NTLMv2 authentication requires access to a third-party library. To record and execute a test that contains NTLMv2 authentication, you must download the library and place it at the right location.

Before you begin

Before you can test SOAP-based services that use security algorithms, you must obtain and install a third-party library file.

About this task

By default, the HTTP test generation does not enable NTLMv2 authentication, even if it was part of the recording. To automatically enable the correct NTLM version from the recording, set the Generated NTLM Version setting to Guess from recorded data in the HTTP Test Generation preferences.

Procedure

To configure the workbench to enable NTLMv2 authentication

  1. Download the archive from http://jcifs.samba.org/src/jcifs-1.3.18.zip
  2. Unarchive the zip file and copy the JAR file to the installation directory: InstallationDirectory\plugins\com.ibm.rational.test.lt.provider_<version>
  3. To automatically enable the correct NTLM version from the recording, In the workbench, click Window > Preferences > Test > HTTP Test Generation and set the Generated NTLM Version setting to Guess from recorded data.

Results

When a test was recorded with NTLMv2, the Generated NTLM Version setting is selected in the test editor, under NTLM Authentication.
Feedback